HSRPやVRRPの使い方【静的ルート冗長化も解説】

ネットワークでデフォルトゲートウェイを冗長化する場合はHSRPやVRRPの技術を利用します。
実はHSRPやVRRPを応用することで静的ルーティングを冗長化することも出来たりします。
本記事では二つの使い方の構成例やConfigサンプルを記載します。
(似た動きをしているので本記事ではHSRPベースで解説します)

HSRPとは

HSRPはデフォルトゲートウェイ冗長化技術す。

通常、PCに設定できるデフォルトゲートウェイは1つなので、
せっかくデフォルトゲートウェイの機器を2台用意しても、
片方の機器が壊れると通信出来なくなってしまいます。

PCのデフォルトゲートウェイ設定画面
(1セグメントに対して1つデフォルトゲートウェイを設定する)

デフォルトゲートウェイ機器障害時の通信イメージは下図の通りです。
機器障害によりデフォルトゲートウェイのIPアドレスが失われるため、他ネットワークに通信出来なくなります。

デフォルトゲートウェイが冗長化されていない構成における正常系/異常系

HRSPの一般的な実装例

HSRPはデフォルトゲートウェイ機器の間で仮想IPアドレスを設定し、
その仮想IPアドレスをPCのデフォルトゲートウェイに設定することで機能を実現できます。

HSRPによってデフォルトゲートウェイを冗長化することにより、機器障害時も疎通可能

上図構成のConfigは以下の通り。

【L3SW#1】
interface Vlan10
ip address 10.0.10.251 255.255.255.0
standby 10 ip 10.0.10.254
standby 10 priority 105
standby 10 preempt

【L3SW#2】
interface Vlan10
ip address 10.0.10.252 255.255.255.0
standby 10 ip 10.0.10.254
standby 10 priority 95
standby 10 preempt




…仮想IPアドレスを設定
…通常時のActive/Standbyを設定

…障害復旧時の自動Active切り戻しを設定
 ※間の「10」は機器内でHSRPを管理するグループID

障害時は待機系へ自動切り替わりしてくれるので、
機器保守まで通信出来ない。なんてことがなく非常に便利な技術です。

HSRPの応用例

本題です。
デフォルトゲートウェイの設定値 = 静的ルートのネクストホップです。

つまり、HSRPでネクストホップを冗長化が出来るということは、
静的ルートの冗長化が出来るということ
です。

例えば下図の様に、異なる会社間でネットワークを接続する場合、
お互いの管理する自ルータから、相手ネットワークに向けて静的ルートを設定し合うことがあります。
(境界で動的ルートを利用したくない要件など)

下図の様に機器が冗長化されている場合、HSRPを利用して静的ルートのネクストホップを冗長化します。

上図構成のConfigは以下の通り。

A社の設定

【L3SW#1】
interface Vlan255
ip address 172.16.255.252 255.255.255.248
standby 1 ip 172.16.255.254
standby 1 priority 105
standby 1 preempt

【L3SW#2】
interface Vlan255
ip address 172.16.255.253 255.255.255.248
standby 1 ip 172.16.255.254
standby 1 priority 95
standby 1 preempt




…仮想IPアドレスを設定

B社の設定(静的ルートは同じ設定となる)

【L3SW#4】
ip route 10.0.0.0 255.128.0.0 172.16.255.254

【L3SW#4】
ip route 10.0.0.0 255.128.0.0 172.16.255.254


…A社アドレスレンジを仮想IPアドレスに中継


…A社アドレスレンジを仮想IPアドレスに中継

このConfig例はB社→A社宛ての設定です。
A社→B社宛ても同様にHSRPと静的ルートを準備する必要があります。

以上の構成により、静的ルートの冗長化が可能です。
(冗長化したファイアウォールをLayer3モード+静的ルートで使う際にも応用可能)

まとめ

ちょっと変わったHSRPの使い方ですが、機能単位ではシンプルなので実装は簡単です。
要件や状況に合わせて最適な設計の選択肢が増えることを願っています。

スポンサーリンク

・エンジニアスクール

ネットワークエンジニア始めるならネットビジョンアカデミー(NVA)

・転職

タイトルとURLをコピーしました