VRFの使い方【仮想ルータの仕組みと実装例を解説】

VRFはルータやレイヤ3スイッチに、仮想ルータを作成する技術です。
VRFを駆使することで、柔軟なネットワーク設計に対応可能。
大規模ネットワークの構築・保守業務上、必須技術です。
本記事ではその仕組み、設定例、実装例を図を交えて解説します。

VRFとは

VRF(Virtual Routing and Forwarding)とは
1つのルータやレイヤ3スイッチに、複数の仮想ルータを作成する技術です。

仮想ルータごとに、それぞれ独立したルーティングテーブルを持ちます。
VRFによりレイヤ3で論理的なネットワーク分割が可能になります。

VRFのメリット(他の仮想化技術と同様)
・1つの機器を論理共有できるため、設備コストが安く済む
・機器台数を減らせるため省スペース
・論理変更のみで構成を大きく変えられるため、構築が比較的容易
・コストメリットに優れているため、結果として柔軟な要件に対応可能

VRFの設定

下図の構成を例にVRFのConfig解説をします。

下記3ステップで設定を行います。
朱書き箇所がVRF関連設定です。上図Sales-vrfの設定をメインに解説します。

1.仮想ルータの作成
Router(config)# ip vrf Sales-vrf
Router(config-vrf)# rd 1:10
 ※RD値は任意の値を指定。ASやIPアドレス、ネットワークごとの管理番号と紐づいていると管理しやすい

2.仮想ルータにインタフェース紐づけ
Router(config)# interface VLAN 10
Router(config-if)# ip vrf forwarding Sales-vrf
Router(config-if)# ip address 192.168.10.254 255.255.255.0

Router(config)#interface GigabitEthernet 0/23
Router(config-if)# no switchport
Router(config-if)# ip vrf forwarding Sales-vrf
Router(config-if)# ip address 192.168.255.249 255.255.255.252
 ※上記の通り、VRFはSVIにも物理インタフェースにも設定可能

3.仮想ルータにルーティング適用
Router(config)# ip route vrf Sales-vrf 192.168.20.0 255.255.255.0 192.168.255.250

OSPFの場合は下記のイメージで記述
Router(config)# router ospf 10 vrf Sales-vrf
Router(config-router)# network 192.168.10.0 0.0.0.255 area 0
Router(config-router)# network 192.168.255.248 0.0.0.3 area 0

Router(config)# router ospf 20 vrf Engineer-vrf
Router(config-router)# network 192.168.20.0 0.0.0.255 area 0
Router(config-router)# network 192.168.255.252 0.0.0.3 area 0

VRF実装例

1.ネットワーク分割

VRF設定例の図の様に、管理部署ごとにVRFを分割し、
境界でファイアウォール制御を行う構成は多く見られます。

レイヤ2はTrunkで、レイヤ3はVRFで物理共有・論理分割を行います。

2.ファイアウォールを通したい(ワンアーム構成)

拠点間接続をファイアウォール経由に変更する案件を例に解説します。

上図の通り、既存のレイヤ3スイッチをVRFで論理分割し、
ワンアームでファイアウォールを追加することで簡単に要件を満たせます。

ワンアーム構成については下記記事でも解説しています。

VRF実装によるコマンドの変化

Pingや各showコマンドにVRF指定オプションが必要になります。

Pingコマンド

デフォルト
ping 8.8.8.8

VRF実装後
ping vrf salse-vrf 8.8.8.8

showコマンド

デフォルト
show ip route
show ip ospf neighbor
など

VRF実装後
show ip route vrf sales-vrf
show ip ospf neighbor vrf sales-vrf
など

基本的には vrf [VRF名] オプションを付与します。
vrf * オプションで全てのVRFを指定可能です。

VRFに対応していない技術も

WAAS(WAN高速化)の実装時に利用するWCCPなど、
IOSのバージョンによってはVRFに対応していない機能もあります。

少しでもニッチな技術は、小規模でも必ず概念検証しましょう。

スポンサーリンク

・エンジニアスクール

ネットワークエンジニア始めるならネットビジョンアカデミー(NVA)

・転職

タイトルとURLをコピーしました